Erro no VisualG ?? Esperava encontrar entao

18/05/2020

4

Olá, estou criando um codigo, mas na hora de executar aparece: "VisualG esperava encontrar entao"; porém, ele claramente ja está ali, o que fiz de errado, estou começando, geralmente pego o erro depois de um tempo, porém, desta vez não consegui, por isso vim buscar feedback, segue o código:



algoritmo "Seletor Show"
var
Idade,Prop: Inteiro
Sexo,Cabelo, Seq: Caractere
inicio
prop <- 0
Repita
   EscrevaL("=====================")
   EscrevaL("SELETOR DE CANDIDATOS")
   EscrevaL("=====================")
   EscrevaL("Qual seu Sexo [H/M]? ")
      Leia (Sexo)
   EscrevaL("Qual sua idade ? ")
      Leia (Idade)
   EscrevaL("Qual a cor do seu cabelo ?")
   EscrevaL("[1] Castanho")
   EscrevaL("[2] Loiro")
   EscrevaL("[3] Ruivo")
   EscrevaL("[4] Preto")
      Leia (Cabelo)
      Se(Idade => 18)E(Sexo="H")E(Cabelo="1")entao
         Prop <- prop + 1
      Senao
      Fimse
      Se(Idade=>25)E(Idade=<30)E(Sexo="M")E(Cabelo="2")entao
         Prop <- Prop + 1
      senao
      Fimse
   EscrevaL("Quer continuar [S/N] ?")
      Leia (Seq)
Ate(Seq="N")
   EscrevaL("")
   EscrevaL("O numedo de candidatos propensos é:",Prop)

fimalgoritmo
Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários. Para saber mais sobre o uso de cookies,
consulte nossa política de privacidade. Ao continuar navegando em nosso site, você concorda com a nossa política.

Aceitar