Erro que não é erro...

02/12/2012

pessoal, estou utilizando o Eclipse for PHP, não sei se isso tem haver com esse pequeno probleminha,
no meu caso, as coisas funcionam normalmente, mais ou menos, hehehe, quando eu rodo o php aparece um erro, uma caixa vermelho com amarelo, mas quando eu uso alguma funcionalidade essa mensagem some, ou seja, ha apenas uma mensagem que não impede o funcionamento, o que pode ser isso???

PHP

Marcio Araujo

Respostas

03/12/2012

Fernando Vr

pessoal, estou utilizando o Eclipse for PHP, não sei se isso tem haver com esse pequeno probleminha, no meu caso, as coisas funcionam normalmente, mais ou menos, hehehe, quando eu rodo o php aparece um erro, uma caixa vermelho com amarelo, mas quando eu uso alguma funcionalidade essa mensagem some, ou seja, ha apenas uma mensagem que não impede o funcionamento, o que pode ser isso???


Qual a mensagem do erro? pode ser muitas coisas, uma delas é de dar um erro por vc estar pedindo dados de algo q está vazio que só é preenchido depois da função executada.

por exemplo se vc usar o comando $_POST, ele pode retonar um erro antes do formulário ser enviado, pois o post ainda não foi enviado, e os erros somem depois q vc enviar o formulário, pq assim o comando post é preenchido.

Nesse caso um jeito de resolver é colocando o @ por exemplo @$_POST, então se caso ele não for enviado o post ele não retorna nada evitando erros.

Mas qualquer coisa coloca ai o erro q aparece, e qual código está usando na linha mencionada no erro.

Abraços
Responder Citar

03/12/2012

Fernando

Pessoal segue um curso de php orientado a objetos que estarei ministrando online: http://stoodos.com/c/php-orientado-a-objetos/99
Responder Citar

04/12/2012

Marcio Araujo

FernandoVR, vou testar com esse @, vlw!!!
Responder Citar

04/12/2012

Marcio Araujo

deu certo, muito obrigado...

só uma pequena duvida, é normal quando pelo browser tentar acessar os arquivos, aparecer uma listagem com uma imagem não identificada???
Responder Citar

07/12/2012

Fernando Vr

deu certo, muito obrigado... só uma pequena duvida, é normal quando pelo browser tentar acessar os arquivos, aparecer uma listagem com uma imagem não identificada???


Se for o q eu estou pensando é normal sim Marcio Araujo, isso acontece pq o Apache não vem configurado com as imagens, porém tem um modo de configurar isto, veja a minha listagem como q está e se é isso mesmo o q vc se refere na sua pergunta:

http://i46.tinypic.com/64fomb.jpg


Responder Citar