Fire Bird 2.1 não instala no Win-98

22/01/2010

1

Caros amigos!
Sou Dev. Delphi-7 + DBexpress + FB 2.1

Tive q instalar o FB-2.1 em uma maquina cujo SO é o Win-98, mas quando chega a 70% da instalação, o programa para e me avisa que uma dll não pode ser copiada porque está corrompida. Fiz várias tentativas mas o erro ocorre sempre no mesmo lugar. Estou tentando apenas instalar o Cliente, mas mesmo assiM nada. Tentei copiar somente a FBclient.dll para a pasta do aplicativo e tbém copiei para System, agora o aplicativo não encontra a dll FBclient.dll, mesmo já estando na pasta do aplicativo. Solução, instalei o FB 1.5 cliente para fazer a comunicacao com o servidor FB-2.1, mas temo algum problema.

A quem puder ajudar nesta, desde já meus agradecimentos.

100+

ANT.CARLOS/SP


Responder

Posts

09/03/2010

Alison Bissoli

[cite]   Porque o FB 2.1 não roda no Windows NT? O Firebird 2.1 para Windows é compilado usando o MS Visual C 2005 e, portanto, depende do runtime do mesmo para ser executado. No entanto, segundo a página da Microsoft, o runtime do VC 2005 não é compatível com o Windows NT e Windows 95. Sendo assim, caso você queira utilizar o FB 2.1 em máquinas com Windows NT, terá que compilar seu próprio Firebird, usando um compilador mais antigo. O mesmo vale para instalar o Client do Firebird, pois ele também depende deste runtime. Extraído do site da Microsoft:
Supported Operating Systems: Windows 2000 Service Pack 3; Windows 98; Windows 98 Second Edition; Windows ME; Windows Server 2003; Windows XP Service Pack 2 Autor: Carlos H. Cantu [/cite]   Extraído do site www.firebase.com.br
Responder

09/03/2010

Alison Bissoli

Creio que no seu caso, terá que fazer também uma compilação sua para o windows 98.
Responder
×
+1 DevUP
Acesso diário, +1 DevUP
Parabéns, você está investindo na sua carreira