formula =ESQUERDA no Excel. :(

04/02/2020

10

Bom dia.

Estou tendo um probleminha com a formula =ESQUERDA no excel
A B
1 1 ESQUERDA(A1;1)
2 2 ESQUERDA(A2;1)
3 3 ESQUERDA(A3;1)
4 4 ESQUERDA(A4;1)
5 5 ESQUERDA(A5;1)
6 6 ESQUERDA(A6;1)
7 7 ESQUERDA(A7;1)
8 8 ESQUERDA(A8;1)
9 9 ESQUERDA(A9;1)
10 1 ESQUERDA(A10;1)
11 1 ESQUERDA(A11;1)
22 2 ESQUERDA(A12;1)
32 3 ESQUERDA(A13;1)
42 4 ESQUERDA(A14;1)
52 5 ESQUERDA(A15;1)

Como observado acima nas células A1 ate A9 ele esta me dando com resultado na célula B o 1 , 2 , 3 ... , 9. E nas demais células esta me dando o resultado realmente esperado. Gostaria de uma solução para nas células B me dar o resultado 0.

Sei que se eu colocar no formato texto dará certo o que quero, mais gostaria de deixar no formato numero mesmo.

Alguém tem experiente no Excel teria uma solução pra me ajudar. Obrigado.
Responder

Post mais votado

05/02/2020

Olá Rubens,

Não sei se entendi bem teu problema, mas tenta assim:

=SE(A1<10;0;ESQUERDA(A1;1))

Abraço
Responder

Mais Posts

05/02/2020

Rubens Pena

Olaa, help.... Alguém pode me ajudar.
Responder

06/02/2020

Rubens Pena

Olá Rubens,

Não sei se entendi bem teu problema, mas tenta assim:

=SE(A1<10;0;ESQUERDA(A1;1))

Abraço
Ola Alec Candia

Funcionou perfeitamente, era justamente esse o resultado final que eu almejava. Obrigado.
Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários. Para saber mais sobre o uso de cookies,
consulte nossa política de privacidade. Ao continuar navegando em nosso site, você concorda com a nossa política.

Aceitar