Java e Firebird

04/01/2006

2

Como fazer a conexão a Firebird com o Java ?

Ao tentar fazer a conexão usando o compilador NetBeans, me apareceu o seguinte erro:

java.lang.UnsupportedClassVersionError: org/firebirdsql/jdbc/FBDriver (Unsupported major.minor version 49.0)
at java.lang.ClassLoader.defineClass0(Native Method)


Responder

Posts

04/11/2006

Lordalmma

posta seu código de conexão com o BD para eu dar uma olhada, por gentileza^^

OBS: Você deu um
Class.forName(´nome_da_classe_do_ODBC´)?

Por exemplo, para o JOdbc:Odbc da Sun, faz-se assim:
Class.forName(´sun.jdbc.odbc.JdbcOdbcDriver´);

Tem que ter essa definição.
Se não tiver, ele não passa...

mas se não for isso, posta aew o código seu de conexão para eu dar uma olhada^^

Eu tenho umas rotinas com Firebird em algum lugar... qq coisa dou uma procurada pra vc^^


Responder
×
+1 DevUP
Acesso diário, +1 DevUP
Parabéns, você está investindo na sua carreira