Lógica programação - exemplo

11/01/2018

2

Crie um programa que armazene 10 números em um vetor A e gere um vetor B cujos elementos consistem no quadrado dos elementos de A.

Exemplo:

A[1]=4 B[1]=16
A[2]=3 B[2]=9
A[3]=6 B[3]=36

se alguém souber por favor me ajude ;)
Responder

Posts

11/01/2018

Luiz Vichiatto

Ana, a codificação fica por sua conta na linguagem de sua preferencia, o processo é assim

//declarando
var
	a,b:vetor[0..9] de inteiro
	
	c,e: inteiro
	
inicio
c=0;
enquanto c < 10  faça
	escreva ("Digite número: ")
	leia (e)       //lendo o valor do teclado após o ENTER
 	a[c] = e       // atribuindo o valor de e para a posição do vetor A
	b[c] = e * e   // atribuindo o quadrado do número ao vetor B
	
	imprima "Vetor A posisão "+ c +" é " a[c] + ", Vetor B posisão " + c + " é " + b[c] //Imprimindo para verificar se está correto
fim enquanto
Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários. Para saber mais sobre o uso de cookies,
consulte nossa política de privacidade. Ao continuar navegando em nosso site, você concorda com a nossa política.

Aceitar