Motorola V635 problemas com null

11/11/2007

1

Boa noite pessoal

Tudo bem?
Fiz uma aplicação em jme usando o Motorola v635
O problema é q qdo minha midlet não encontra o usuário no banco de dados remoto, a aplicação é fechada, pois um null pointer é encontrado
Veja a saída do console

Mensagem do catch CommandAction Login... java.lang.NullPointerException  esta mensagem está correta, ela aparece toda vez q o usuário esquece de digitar algo no text field

Enviando String url: http://200.148.136.3:8080/Servidor/ServletSAP?command=fazerlogin

Enviando a String login ( a ) Conectando com o servidor para buscar login

Passei no try open data input stream...

URLwithID: http://ip do meu servidor/Servidor/ServletSAP;jsessionid=4238F7CEA8C58A9A5D7A6514AF46A453

Url: http://ip do meu servidor /ServletSAP;jsessionid=4238F7CEA8C58A9A5D7A6514AF46A453

String loginResult tem o valor ...vazio

if loginResult == vazio --> String loginResult tem o valor... vazio

Uncaught exception java/lang/NullPointerException  olha o null pointer aki!!!

ALERT: uncaught Exception found

JK_VMEVENT_VMSTOPPED

AMstartMidpApplication return code = -127

finish WINSOCK success.


O problema está q eu estou tratando isso no servlet, lá eu passo o valor vazio para a string q armazena o resultado da busca no banco... mesmo assim, o null está chegando no celular e fazendo a runtime encerrar a aplicação.... gente, alguém sabe m dizer como resolvo isso... é um pouco urgente, tenho q entregar meu trabalho esta semana

Obrigada de coração


Responder
×
+1 DevUP
Acesso diário, +1 DevUP
Parabéns, você está investindo na sua carreira