PORTUGOL DESVIO DIRECIONAL ANINHADO

18/02/2022

7

Boa tarde, estou começando com programação porém senti uma dificuldade em entender o desvio direcional aninhado, fiz um codigo porém não sei se está com este desvio, alguém poderia ver o código e me explicar se está certo e se não, o que é?
Pois pelo que entendi o SENAO deveria estar dentro do SE, porém não consigo colocar ele, ele da erro, obrigado.

programa
{
funcao inicio()
{
inteiro nota
escreva("Digite sua nota ---> ")
leia(nota)
se(nota > 5) { // abertura 1 escopo
escreva("Está aprovado!")
} //fechamento 1 escopo
senao{ //abertura escopo senao
se(nota ==5){ // abertura escopo 2
escreva("Você está de recuperação!")
} // fechamento escopo 2
senao{ //abertura escopo senao2
se(nota < 5){ // abertura escopo 3
escreva("Você está reprovado!")
} // fechamento escopo 3
} // fechamento escopo senao2
} // fechamento escopo senao
} // fechamento escopo funcao
}
L74n

L74n

Responder

Post mais votado

09/03/2022

programa
{

	funcao inicio()
	{

		inteiro nota
		escreva("Digite sua nota ---> ")
		leia(nota)

		// quando possível, parta da igualdade
		se(nota == 5) { // abertura escopo recuperacao
			escreva("Você está de recuperação!")
		} // fechamento escopo recuperacao
		senao{ //abertura escopo senao
			se(nota > 5) { // abertura escopo aprovado
				escreva("Está aprovado!")
			} //fechamento escopo aprovado
			senao { // abertura escopo reprovado
				escreva("Você está reprovado!")
			} //fechamento escopo reprovado
		} //fechamento escopo senao

	} // fechamento escopo funcao

} // fechamento escopo programa

Emerson Nascimento

Emerson Nascimento
Responder

Mais Posts

09/03/2022

Assis Ferreira

Amigo, desculpe, não sei se já te responderam, mas o pessoal
fica com preguiça de ler código com essa bagunça. poste assim
não precisa os comentários de abertura e fechamento de "escopo"


programa
{
funcao inicio()

{
inteiro nota

escreva("Digite sua nota ---> ")
leia(nota)

se(nota > 5) {
escreva("Está aprovado!")

}senao{
se(nota ==5)
{
escreva("Você está de recuperação!")


} senao{
se(nota < 5)
{
escreva("Você está reprovado!")

}
}
}
}
}

E seu código está certo
Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários,
consulte nossa política de privacidade.

Aceitar