problema Action new_post

21/05/2020

3

Boa tarde pessoal,



acredito que estou com o problema e a solução no post só que nao sei exatamente aonde alterar o codigo.

Um site de servidor de games de um cliente esta com um problema na aba forum. é um  forum simples para questoes relacionadas ao game.

Irei anexar alguns prints para facilitar o entendimento e o codigo.

Resumindo: O problema é que o forum tem algumas boards (News, Wars, Quests, Pictures e Bug reports), suponhamos que dessas boards Pictures tem 4 posts e Quests 1 post. Se o primeito post do forum for em Pictures, quando eu tentar abrir o post de Quests ele ira me redirecionar para Pictures, e dentro de pictures terá todos os posts de todas as boards. Se eu tentar excluir algum topico de qualquer board, todos os topicos são excluidos.

Acredito que o problema esteja no criação do ID do post na database, todos estão sendo gerados como ID 0. Imagino que a função new_post não está trabalhando corretamente.

se alguem puder me ajudar eu fico muito agradecido mesmo!! to quebrando a cabeça aqui a um tempo, só falta isso pra terminar.


PRINTS E EXPLICAÇÃO:

https://i.ibb.co/d2YBNhh/todososboards.jpg - print de todos as boards

https://i.ibb.co/QNJtbK8/boardwar.jpg - print da board war (observe que existe apenas um post nessa board)

https://i.ibb.co/gmxN0bS/teste.jpg - print apos selecionar post da board war (repare que fui redirecionado para a board Report Bug que foi a que eu criei o primeiro post do forum como expliquei acima no resumo)

https://i.ibb.co/3Y7mWtb/databasezforum.png - print do banco de dados (todos os IDs são 0)
Joao

Joao

Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários,
consulte nossa política de privacidade.

Aceitar