Problema com Lógica no VisualG

06/05/2018

5

Eu gostaria que alguém me ajudasse no quesito de imprimir menor e maior idade de um grupo de pessoas, não entendo pq tem que se definir variáveis menor_idade com valor alto e menor_idade com valor baixo ?
Ítalo Guimarães

Ítalo Guimarães

Responder

Posts

07/05/2018

Davi Emboaba

Manda o código, amigo. Difícil ajudar sem abstrair o código. Mas pelo que entendi, seriam parâmetros de comparação comparação para conseguir se ter um resultado para poder ser gerado a "impressão".
Responder

16/05/2018

Ítalo Guimarães

É exatamente isso Davi, pois estou iniciando com a programação, e não estou conseguindo fazer um algoritmo que imprima maior e menor idade de um grupo de pessoas, eu vou mandar um que eu peguei na net, porém não entendo pq tem que se definir variáveis menor_idade com valor alto e menor_idade com valor baixo

Var
// Seção de Declarações das variáveis
idades, cont, mais_velha, media, maiorvinte, quant, mais_nova: inteiro

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc...
cont:= 1
mais_velha:= -1000
media:= 0
maiorvinte:= 0
mais_nova:= 1000

escreva("Leia quantidade de pessoas: ")
leia(quant)

//para cont de 1 ate quant faca
//enquanto cont <= quant faca

repita

escreva("Idade da", cont, "ª pessoa: ")
leia(idades)

media:= media + idades

se idades > 20 entao
maiorvinte:= maiorvinte + 1

fimse

se idades > mais_velha entao
mais_velha:= idades

fimse

se idades < mais_nova entao
mais_nova:= idades

fimse


cont:= cont + 1

ate cont > quant

//fimenquanto
//fimpara


escreval("A mais velha tem ", mais_velha, " anos.")
escreval("A mais nova tem ", mais_nova, " anos.")
escreval("A média das idades é: ", media/quant, " anos.")
escreval("A idade maior que 20 ano é: ", maiorvinte)

Fimalgoritmo

Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários,
consulte nossa política de privacidade.

Aceitar