Problemas com VB.NET 4.0

04/06/2012

Bom dia galera,

Tenho um sistema em VB.NET e no framework 1.1, fiz a migração para o VS 2010 ocorreu tudo certo aparentemente, mas algumas funcionalidades básicas como um Selected_ChangeComboBox não funciona.

Gostaria de saber o que posso fazer para resolver esse problema.

Valeu galera e até mais.

Felipe Ggs

Respostas

08/06/2012

Joel Rodrigues

Como assim não funciona? Trata-se de um evento, certo?
Experimente adicionar este evento novamente ao controle e depurar o código para ver se o mesmo está sendo executado.
Responder Citar

18/06/2012

Felipe Ggs

Desculpe a demora para a resposta, eu estava com problemas na minha base de dados e consegui resolver só agora.

Mas o que acontece é o seguinte, eu já tentei criar o evento novamente, mas quando eu vou debugar vejo que o evento é carregado no load da página e não quando é clicado no ComoBox, ou seja, quando ele passa pelo o load da página o ComboBox esta vazio e não ocorre alteração nenhuma, e quando clica nele as alterações que estão programadas para serem feitas não ocorrem, ele nem entra no método quando eu faço o debug. E também é estranho que quando clico no ComboBox ele pede para eu abrir uma nova instancia do VisualStudio 2010 e praticamente toda hora fica aparecendo erros de JavaScript, também já desabilitei o a depuração de JS no IE, mas não adiantou. O mais estranho é que na versão antiga (.NET 1.1) ele funciona normalmente.
Responder Citar

18/06/2012

Joel Rodrigues

A propriedade AutoPostBack do ComboBox está como true?
Responder Citar

19/06/2012

Felipe Ggs

Sim ela estava como True, já tentei mudar para false mas continua dando o mesmo erro.
Responder Citar

19/06/2012

Joel Rodrigues

Tente usar o IsPostBack para executar a rotina:
if(IsPostBack)
{
//execute aqui
}
Responder Citar

21/06/2012

Felipe Ggs

Eu tentei essa função mas também não deu certo. Fui verificando consegui encontrar o erro, era que eu estava setando o valor do comoboBox na propriedade SelectedIndex = 0, aí eu só troquei para SelectedValue = e funcionou normalmente.

o problema de carregamento dos comboBox consegui resolver, mas as vezes quando é clicado em um comboBox (para fazer o carregamento de outro por exemplo) o sistema volta na tela de login, pedindo sempre para abrir uma nova instância do VisualStudio, e ele consta também um erro da seguinte forma Internal .Net FrameWork Data Provider error 1., eu uso um framework interno mas não encontrei nada dentro do código fonte dele que possa ter causado esse erro.
Responder Citar