Programa cadastro usuário Visualg

31/08/2021

5

Ola Mestres!
Fiz esse programa que possui a função de cadastrar o nome validando se a posição do vetor estiver vazia. Porém, ele valida a posição vazia so que nao volta pro início da repetição pra continuar gravando até o contador ser igual a quantidade usuários que quero cadastrar. Segue o código a baixo:

Algoritmo "semnome"
// Disciplina : [Linguagem e Lógica de Programação]
// Professor : Antonio Carlos Nicolodi
// Descrição : Aqui você descreve o que o programa faz! (função)
// Autor(a) : Nome do(a) aluno(a)
// Data atual : 28/08/2021
Var
// Seção de Declarações das variáveis
opcao, cont, quant, posicao : inteiro
nome : vetor[1..5] de caracter

procedimento menu()
inicio
enquanto opcao <> 3 faca
escreval ("--------------------")
escreval ("** MENU DE OPÇÕES **")
escreval ("--------------------")
escreval ("Digite 1 para cadastrar o usuário")
escreval ("Digite 2 para mostrar usuários")
escreval ("Digite 3 para finalizar o programa")
leia(opcao)
escolha opcao
caso 1
cadastro()
caso 3
para cont de 1 ate 5 faca
nome[cont]<-"x"
fimpara
escreval ("Obrigada volte sempre")
fimescolha
fimenquanto
fimprocedimento

procedimento cadastro()
inicio

escreval ("-----------------------------------------------")
escreval ("Quantas pessoas serão cadastradas? min 1 max 5")
leia (quant)

para cont de 1 ate quant faca
se nome[cont] = "" entao
escreval("Digite o nome")
leia(nome[cont])
cont <- cont + 1
senao se nome[cont] <> "" entao
escreval("Posicao ocupada")
cont <- cont + 1
quant <- quant + 1
fimse
fimpara

fimprocedimento

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc...
menu()

Fimalgoritmo




Será que alguem conseue ajudar?
Daiane

Daiane

Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários,
consulte nossa política de privacidade.

Aceitar