Projeto delphi for php não funciona pelo browser.

15/05/2007

1

Desenvolvemos o projeto da video-aula 2. Quando mandamos excecutar dentro do delphi for php ele funcionona perfeitamente. Fomos no ´tools´, ´deployment wizard´ para exportar as VCLs para nossa pasta: c:\inetpub\wwwroot\testeaula. O deployment concluiu com sucesso.

Quando tentamos excecutar: http://localhost/testeaula/unit1.php, recebemos os seguintes erros:

--------------------------

Warning: session_start() [function.session-start]: open(C:\DOCUME~1\ADMINI~1.000\CONFIG~1\Temp\php\upload\sess_9lgob9ftpg106l1ctlv610sp85, O_RDWR) failed: No such file or directory (2) in C:\Inetpub\wwwroot\testeaula\vcl\forms.inc.php on line 77

Notice: Trying to get property of non-object in C:\Inetpub\wwwroot\testeaula\vcl\dbtables.inc.php on line 517

Notice: Undefined property: Table::$Active in C:\Inetpub\wwwroot\testeaula\vcl\dbtables.inc.php on line 631

Notice: Undefined property: Table::$Active in C:\Inetpub\wwwroot\testeaula\vcl\dbtables.inc.php on line 631

Notice: Only variable references should be returned by reference in C:\Inetpub\wwwroot\testeaula\vcl\dbtables.inc.php on line 281

Notice: Undefined property: Table::$Active in C:\Inetpub\wwwroot\testeaula\vcl\dbtables.inc.php on line 631

Notice: Undefined property: Table::$State in C:\Inetpub\wwwroot\testeaula\vcl\db.inc.php on line 1102

Notice: Undefined property: Table::$State in C:\Inetpub\wwwroot\testeaula\vcl\db.inc.php on line 1102

Notice: Undefined property: Table::$Active in C:\Inetpub\wwwroot\testeaula\vcl\dbtables.inc.php on line 631

Notice: Undefined property: Table::$State in C:\Inetpub\wwwroot\testeaula\vcl\db.inc.php on line 1102

Notice: Undefined property: Table::$State in C:\Inetpub\wwwroot\testeaula\vcl\db.inc.php on line 1102

Notice: A session had already been started - ignoring session_start() in C:\Inetpub\wwwroot\testeaula\vcl\rpc\rpc.inc.php on line 240

----------------------------

Solicitamos ajuda.[/code]


Responder

Posts

18/05/2007

Tchucky

Vc tem quer o php5 instalado no seu servidor para o programa rodar


Responder

09/06/2007

Filipe.tenista

Consegui rodar perfeitamente diversos testes com Linux + Apache2 + PHP5


Responder

17/10/2007

Lcfinformatica

Resolvi o problema.


Responder

06/04/2008

Sistemald

Como você resolveu???


Responder

15/04/2008

Jpdo

como resolveu?


Responder

15/04/2008

Sistemald

cheguei a conclusão que este produto deveria ser uma versão Alpha(ou seja nem beta ainda), existem muitos bug´s, e alguns sérios. No mínimo ela deveria ser gratuita.

Resumindo:

Não vale a pena pagar por esta ferramenta com tantos problemas. A CodeGear não deveria ter assinado seu nome nesta ferramenta.


Responder

18/04/2008

Jpdo

concordo convosco, de que esta ferramenta tem muitos bugs!


Responder

18/04/2008

Webmoura

O problema e o Deploywizard, que nao copia toda a VCL, como deveria, entao para resolver o problema e simplesmente copiar esta pasta (VCL) para dentro da pasta do seu projeto no servidor, que ai tudo funciona.

So uma coisa, esta ferramenta ainda esta na versao 1.02 com isso existem alguns bugs que ainda estao sendo acertados, muitos deles devem ser corrigidos, pelo menos e o que esta escrito no site da Codegear, com a versao 2.0.

Em nossa empresa estamos utilizando esta OTIMA ferramenta, que esta agilizando muito nosso tempo de programacao e desenvolvimento.

Espero ter ajudado
webmoura


Responder
×
+1 DevUP
Acesso diário, +1 DevUP
Parabéns, você está investindo na sua carreira