QuickReport

05/01/2006

Prezados comapnheiros do Forum,

Estou tentando imprimir com delphi 7 e quickreport com windows Xp e lx-300, ja defini o novo formulario 240x280 mm (form. Continuo), so que a segunda pagina vai desposicionando (O relatorio assume A4 210x297mm), a lx-300 nao esta aceitando o novo formulario, se eu instalo a lx-300+ aceita o formulario mas dá incompatiblidade, ja tentei usando impressora generica somente texto, tambem nao resolve. Estou no aguardo. Obrigado.


Emrinfo

Respostas

05/01/2006

Eixox

Não sei se estou certo, porém eu também desenvolvo com Delphi 7 e Quick Report e incrivelmente também uso LX-300, AP-2000 e LX-810.

Bem pelo que eu saiba, eu defino no Quick Report o papel como padrão Letter (Carta), não defino as dimensões. A impressão sempre sai correta.
O que eu sempre faço questão de dizer para meus clientes é tomarem cuidado com o padrão definido no próprio Windows XP - deixar sempre o padrão Carta. Use a propriedade [b:77af328739]PageSize [/b:77af328739]em [b:77af328739]Page[/b:77af328739] como [b:77af328739]Letter[/b:77af328739]. Tudo deverá sair corretamente.


Responder Citar

06/01/2006

Emrinfo

Resolveu o meu problema, e vejo no forum muitas pessoas com o mesmo problema. Obrigado. :D


Responder Citar

11/01/2006

Fabiano_aprendiz

Estou com um problema identico, e defini o papel como carta tanto na impressora como no QuickReport, mas continua imprimindo como A4, saberiam dizer o q pode ser? Tbm uso Win XP e LX300


Responder Citar

12/01/2006

Emrinfo

Define na impressora como formulario padrao Carta.


Responder Citar

12/01/2006

Fabiano_aprendiz

Está definido, tanto na impressora como no Report Settings do QuickReport, mas mesmo assim continua saindo como se fosse A4. Uso delphi 5.


Responder Citar

24/01/2006

Fabiano_aprendiz

Algum de vocês tem uma versão do QuickReport mais recente que a 3.0? E que a reprogramação do tamanho de papel funcione, pois uso a 3.0 mas as alterações q são feitas no tamanho do papel não estão sendo obedecidas. Em caso de positivo, tem como me enviar?
Desde já agradeço.


Responder Citar