WCF + EntityFramework 5 Code First

15/10/2012

9

Olá Pessoal, estou com um problema em um sistema no qual estou desenvolvimento para o meu TCC no qual tenho que implementar um servico WCF utilizando a orm entity framework code first para acesso a dados, o problema é que quando tento consumir o meu servico para implementar uma lista de qualquer objeto da o seguinte erro:

{"Erro ao receber a resposta HTTP para http://localhost:62133/Service.svc. Isso pode estar relacionado ao fato de que a ligação de ponto de extremidade do serviço não utiliza o protocolo HTTP. Também pode estar relacionado à anulação de um contexto de solicitação HTTP pelo servidor (possivelmente devido ao desligamento do serviço). Consulte os logs do servidor para obter mais detalhes."}

o detalhe é, na insercao funciona tudo ok, o problema é apenas quando preciso recuperar os dados

alguem tem alguma ideia do que pode estar acontecendo???

ATT.
Alberto Amorim
Responder

Posts

17/10/2012

Alberto Amorim

Resolvido, o entity por padrão está configurado para gerar um proxy automaticamente, a solução então é desativar essa opção com o o comando abaixo:

DbContext.Configuration.ProxyCreationEnabled = false;
Responder

17/10/2012

Alisson Santos

Peço que o responsável possa colocar o tópico como concluido.
Responder

17/10/2012

Joel Rodrigues

Beleza, Alisson.
Estou encerrando o tópico.
Responder

17/10/2012

Alberto Amorim

o problema é que não aparece nenhuma opção para finalização do topico, alguem saberia informar? pelo visto muitos usuarios tem tido o mesmo problema
Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários. Para saber mais sobre o uso de cookies,
consulte nossa política de privacidade. Ao continuar navegando em nosso site, você concorda com a nossa política.

Aceitar