Problema Linux - React

07/02/2020

7

Recentemente troquei meu o.s de win10 para ubuntu 18.04 e fui tentar criar uma aplicação react. No entanto eu objetive a seguinte mensagem no terminal:


yarn add v1.21.1
[1/4] Resolving packages...
[2/4] Fetching packages...
info fsevents@1.2.11: The platform "linux" is incompatible with this module.
info "fsevents@1.2.11" is an optional dependency and failed compatibility check. Excluding it from installation.
info fsevents@2.1.2: The platform "linux" is incompatible with this module.
info "fsevents@2.1.2" is an optional dependency and failed compatibility check. Excluding it from installation.
[3/4] Linking dependencies...
warning "react-scripts > @typescript-eslint/eslint-plugin > tsutils@3.17.1" has unmet peer dependency "typescript@>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta".
warning "react-scripts > eslint-config-react-app@5.2.0" has incorrect peer dependency "eslint-plugin-flowtype@3.x".


Consequentemente, após a instalação eu não conseguir iniciar a aplicação por meio do script: yarn start ou npm start.
Gostaria de saber se já ocorreu com algúém, e se sim por favor compartilhem a solução para que eu possa dar continuidade no aprendizado dessa tecnologia. Agradeço desde já! Abs.
Responder

Posts

Processos para instalação do React no Ubuntu:

https://www.zeolearn.com/magazine/setup-react-ubuntu
Responder

Utilizamos cookies para fornecer uma melhor experiência para nossos usuários. Para saber mais sobre o uso de cookies,
consulte nossa política de privacidade. Ao continuar navegando em nosso site, você concorda com a nossa política.

Aceitar